Does tomcatspnego support NTLM v2?

Sep 4, 2014 at 3:02 PM
Edited Sep 4, 2014 at 3:04 PM
Can you please tell me whether tomcatspnego supports NTLM v2?
Coordinator
Sep 5, 2014 at 3:20 PM
Hello,

Yes

By default, tomcatspnego uses SPNEGO.
When the browser cannot use Kerberos, it will use NTLMv2.
When the user does a request with the DNS name of the server, Kerberos will be used.
Else, the browser will use NTLM v2.

The method NTLM can also be used with a parameter, but it is only for the old NTLM v1. You will use this authentication method when your client is very old or when you cannot use SPNEGO (example: IOS or Android)

Dominique